Android version 1.5

This is just a short announcement to warn that support for Android OS 1.5 in future versions of Pirates and Traders will most likely cease. Pirates and Traders was originally coded for a HTC Magic phone running Android 1.5, but Android soon moved on to more advanced frameworks. Fortunately, Pirates and Traders is not very complicated graphically, but it has always been a little bit of a pain to support the older versions of Android as 1.5 (and to a lesser extent 1.6) include a number of bugs that require somewhat special treatment.

With the latest versions of P&T, however, we are getting to the point where maintaining backward compatibility is no longer viable. I no longer own 1.5 hardware to test against, so I can no longer be certain that the changes I am making are not going to break something on these phones. As a result, I will be switching “off” the bit that allows 1.5 to be supported in one of the upcoming releases. The game will not disappear from your phones if you have 1.5, but future updates will not be pushed to the old OS.

Pirates and Traders: Retro will continue to support 1.5.

Thanks for your understanding.

Posted in Announcement, Pirates & Traders.